Browse Source

chore: update azure pipelines (#5611)

- upload coverage report (codecov) from azure pipelines
- only build `dist` once (`dist` is now shared between production jobs)
- run production tests on macOS (not sure why but it's faster than others)
- extract shareable steps
- remove travis/circle
master
Ika 4 years ago
committed by GitHub
parent
commit
f94f63b040
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
  1. 16
      .azure-pipelines/dev.yml
  2. 9
      .azure-pipelines/jobs/dev-lint.yml
  3. 7
      .azure-pipelines/jobs/dev-test.yml
  4. 6
      .azure-pipelines/jobs/prod-build.yml
  5. 6
      .azure-pipelines/jobs/prod-lint.yml
  6. 10
      .azure-pipelines/jobs/prod-pack.yml
  7. 10
      .azure-pipelines/jobs/prod-test.yml
  8. 14
      .azure-pipelines/lint-dist.yml
  9. 17
      .azure-pipelines/lint.yml
  10. 26
      .azure-pipelines/prod.yml
  11. 6
      .azure-pipelines/steps/download-dist.yml
  12. 6
      .azure-pipelines/steps/install-dependencies.yml
  13. 5
      .azure-pipelines/steps/install-nodejs.yml
  14. 11
      .azure-pipelines/steps/publish-code-coverage.yml
  15. 7
      .azure-pipelines/steps/publish-test-results.yml
  16. 6
      .azure-pipelines/steps/upload-dist.yml
  17. 129
      .circleci/config.yml
  18. 1
      .gitignore
  19. 38
      .travis.yml
  20. 6
      README.md
  21. 71
      azure-pipelines.yml
  22. 18
      jest.config.js
  23. 2
      package.json
  24. 215
      yarn.lock

16
.azure-pipelines/dev.yml

@ -1,16 +0,0 @@
steps:
- task: NodeTool@0
inputs:
versionSpec: "$(node_version)"
displayName: "Install Node.js"
- script: yarn install --frozen-lockfile
displayName: "Install dependencies"
- script: yarn test
displayName: "Run tests"
- task: PublishTestResults@2
inputs:
testResultsFiles: "**/junit.xml"
condition: and(eq(variables['REPORT_SUMMARIES'], true), succeededOrFailed())

9
.azure-pipelines/jobs/dev-lint.yml

@ -0,0 +1,9 @@
steps:
- template: ../steps/install-nodejs.yml
- template: ../steps/install-dependencies.yml
- script: yarn check-deps
displayName: "Check dependencies"
- script: yarn lint
displayName: "Lint code"
- script: yarn lint-docs
displayName: "Lint docs"

7
.azure-pipelines/jobs/dev-test.yml

@ -0,0 +1,7 @@
steps:
- template: ../steps/install-nodejs.yml
- template: ../steps/install-dependencies.yml
- script: yarn test
displayName: "Run tests"
- template: ../steps/publish-test-results.yml
- template: ../steps/publish-code-coverage.yml

6
.azure-pipelines/jobs/prod-build.yml

@ -0,0 +1,6 @@
steps:
- template: ../steps/install-nodejs.yml
- template: ../steps/install-dependencies.yml
- script: yarn build
displayName: "Build dist"
- template: ../steps/upload-dist.yml

6
.azure-pipelines/jobs/prod-lint.yml

@ -0,0 +1,6 @@
steps:
- template: ../steps/download-dist.yml
- template: ../steps/install-nodejs.yml
- template: ../steps/install-dependencies.yml
- script: yarn lint-dist
displayName: "Lint dist"

10
.azure-pipelines/jobs/prod-pack.yml

@ -0,0 +1,10 @@
steps:
- template: ../steps/download-dist.yml
- template: ../steps/install-nodejs.yml
- bash: mv $(npm pack ./dist --silent) $(Build.ArtifactStagingDirectory)
displayName: "Pack dist"
- task: PublishPipelineArtifact@0
inputs:
artifactName: "dist.tgz"
targetPath: $(Build.ArtifactStagingDirectory)
displayName: "Upload dist.tgz"

10
.azure-pipelines/jobs/prod-test.yml

@ -0,0 +1,10 @@
steps:
- template: ../steps/download-dist.yml
- template: ../steps/install-nodejs.yml
- template: ../steps/install-dependencies.yml
parameters:
flags: --ignore-engines # prettier@dev requires node v6+
- script: yarn test:dist
displayName: "Run tests on dist"
- template: ../steps/publish-test-results.yml
- template: ../steps/publish-code-coverage.yml

14
.azure-pipelines/lint-dist.yml

@ -1,14 +0,0 @@
steps:
- task: NodeTool@0
inputs:
versionSpec: "$(node_version)"
displayName: "Install Node.js"
- script: yarn install --frozen-lockfile
displayName: "Install dependencies"
- script: yarn build
displayName: "Build dist"
- script: yarn lint-dist
displayName: "Lint dist"

17
.azure-pipelines/lint.yml

@ -1,17 +0,0 @@
steps:
- task: NodeTool@0
inputs:
versionSpec: "$(node_version)"
displayName: "Install Node.js"
- script: yarn install --frozen-lockfile
displayName: "Install dependencies"
- script: yarn check-deps
displayName: "Check dependencies"
- script: yarn lint
displayName: "Lint code"
- script: yarn lint-docs
displayName: "Lint docs"

26
.azure-pipelines/prod.yml

@ -1,26 +0,0 @@
steps:
- task: NodeTool@0
inputs:
versionSpec: $(node_version_for_build)
displayName: "Install Node.js v$(node_version_for_build)"
- script: yarn install --frozen-lockfile
displayName: "Install dependencies"
- script: yarn build
displayName: "Build dist"
- task: NodeTool@0
inputs:
versionSpec: "$(node_version)"
displayName: "Install Node.js v$(node_version)"
condition:
ne(variables['node_version'], variables['node_version_for_build'])
- script: yarn test:dist
displayName: "Run tests on dist"
- task: PublishTestResults@2
inputs:
testResultsFiles: "**/junit.xml"
condition: and(eq(variables['REPORT_SUMMARIES'], true), succeededOrFailed())

6
.azure-pipelines/steps/download-dist.yml

@ -0,0 +1,6 @@
steps:
- task: DownloadPipelineArtifact@0
inputs:
artifactName: "dist"
targetPath: dist
displayName: "Download dist"

6
.azure-pipelines/steps/install-dependencies.yml

@ -0,0 +1,6 @@
parameters:
flags: ""
steps:
- script: yarn install --frozen-lockfile ${{ parameters.flags }}
displayName: "Install dependencies"

5
.azure-pipelines/steps/install-nodejs.yml

@ -0,0 +1,5 @@
steps:
- task: NodeTool@0
inputs:
versionSpec: "$(node_version)"
displayName: "Install Node.js"

11
.azure-pipelines/steps/publish-code-coverage.yml

@ -0,0 +1,11 @@
steps:
- task: PublishCodeCoverageResults@1
inputs:
codeCoverageTool: Cobertura
reportDirectory: $(System.DefaultWorkingDirectory)/coverage
summaryFileLocation: $(System.DefaultWorkingDirectory)/coverage/cobertura-coverage.xml
displayName: "Publish coverage"
condition: and(variables.ENABLE_CODE_COVERAGE, succeededOrFailed())
- script: yarn codecov -f coverage/cobertura-coverage.xml
displayName: "Publish coverage to Codecov"
condition: and(variables.ENABLE_CODE_COVERAGE, succeededOrFailed())

7
.azure-pipelines/steps/publish-test-results.yml

@ -0,0 +1,7 @@
steps:
- task: PublishTestResults@2
inputs:
testResultsFormat: JUnit
testResultsFiles: $(System.DefaultWorkingDirectory)/junit.xml
displayName: "Publish test results"
condition: and(variables.ENABLE_TEST_RESULTS, succeededOrFailed())

6
.azure-pipelines/steps/upload-dist.yml

@ -0,0 +1,6 @@
steps:
- task: PublishPipelineArtifact@0
inputs:
artifactName: "dist"
targetPath: dist
displayName: "Upload dist"

129
.circleci/config.yml

@ -1,129 +0,0 @@
aliases:
# Cache management
- &restore_yarn_cache
restore_cache:
keys:
- v1-yarn-cache
- &save_yarn_cache
save_cache:
paths:
- ~/.cache/yarn
key: v1-yarn-cache
- &restore_deps_cache
restore_cache:
keys:
- v1-deps-cache-{{ checksum "yarn.lock" }}
- &save_deps_cache
save_cache:
paths:
- node_modules
key: v1-yarn-deps-{{ checksum "yarn.lock" }}
- &restore_build_cache
restore_cache:
keys:
- v1-build-cache-{{ .Branch }}
- v1-build-cache-master
- &save_build_cache
save_cache:
paths:
- .cache
key: v1-build-cache-{{ .Branch }}
# Default
- &defaults
working_directory: ~/prettier
docker:
- image: circleci/node:9
version: 2
jobs:
# Install dependencies and cache everything
checkout_code:
<<: *defaults
steps:
- checkout
- *restore_yarn_cache
- *restore_deps_cache
- run: yarn install
- run: yarn check-deps
- *save_deps_cache
- *save_yarn_cache
- persist_to_workspace:
root: .
paths:
- .
# Create the production bundle and cache
build_prod:
<<: *defaults
environment:
NODE_ENV: production
steps:
- attach_workspace:
at: ~/prettier
- *restore_build_cache
- run: yarn build
- *save_build_cache
- persist_to_workspace:
root: .
paths:
- dist
- store_artifacts:
path: ~/prettier/dist
# Run tests on the production bundle
test_prod_node4:
<<: *defaults
docker:
- image: circleci/node:4
steps:
- attach_workspace:
at: ~/prettier
- run: yarn test:dist
# Run tests on the production bundle
test_prod_node9:
<<: *defaults
steps:
- attach_workspace:
at: ~/prettier
- run:
command: yarn test:dist
environment:
REPORT_SUMMARIES: 1
- store_test_results:
path: test-results
# Run tests using the standalone build
test_prod_standalone:
<<: *defaults
steps:
- attach_workspace:
at: ~/prettier
- run:
command: yarn test:dist
environment:
TEST_STANDALONE: 1
workflows:
version: 2
prod:
jobs:
- checkout_code
- build_prod:
requires:
- checkout_code
- test_prod_node4:
requires:
- build_prod
- test_prod_node9:
requires:
- build_prod
- test_prod_standalone:
requires:
- build_prod

1
.gitignore

@ -17,4 +17,3 @@
coverage
.idea
package-lock.json
/test-results

38
.travis.yml

@ -1,38 +0,0 @@
---
language: node_js
node_js:
- node
- "8"
cache:
yarn: true
directories:
- node_modules
env:
global:
- NODE_ENV=development
matrix:
- JOB=test AST_COMPARE=1
matrix:
fast_finish: true
include:
- node_js: "node"
env: JOB=lint
install:
- yarn install
before_script:
- yarn check-deps
script:
- if [ "${JOB}" = "lint" ]; then yarn lint && yarn lint-docs; fi
- if [ "${JOB}" = "test" ]; then yarn test --runInBand --ci; fi
- if [ "${JOB}" = "test" ]; then yarn codecov; fi
branches:
only:
- master

6
README.md

@ -37,12 +37,8 @@
</p>
<p align="center">
<a href="https://travis-ci.org/prettier/prettier">
<img alt="Travis CI Build Status" src="https://img.shields.io/travis/prettier/prettier/master.svg?style=flat-square&label=Travis+CI"></a>
<a href="https://circleci.com/gh/prettier/prettier">
<img alt="CircleCI Build Status" src="https://img.shields.io/circleci/project/github/prettier/prettier/master.svg?style=flat-square&label=CircleCI"></a>
<a href="https://dev.azure.com/prettier/prettier/_build/latest?definitionId=5">
<img alt="Azure Pipelines Build Status" src="https://img.shields.io/azure-devops/build/prettier/79013671-677c-4846-a6d8-3050d40e21c0/5.svg?style=flat-square&label=Azure+Pipelines&branchName=master"></a>
<img alt="Azure Pipelines Build Status" src="https://img.shields.io/azure-devops/build/prettier/79013671-677c-4846-a6d8-3050d40e21c0/5.svg?style=flat-square&label=build&branchName=master"></a>
<a href="https://codecov.io/gh/prettier/prettier">
<img alt="Codecov Coverage Status" src="https://img.shields.io/codecov/c/github/prettier/prettier.svg?style=flat-square"></a>
<a href="https://twitter.com/acdlite/status/974390255393505280">

71
azure-pipelines.yml

@ -4,70 +4,91 @@ trigger:
variables:
AST_COMPARE: true
REPORT_SUMMARIES: true
ENABLE_TEST_RESULTS: true
ENABLE_CODE_COVERAGE: "" # only enable coverage on the fastest job
jobs:
- job: Lint_Linux_Node_v10
displayName: Lint on Linux Node v10
- job: Dev_Lint
displayName: Dev Lint on Linux Node v10
pool:
vmImage: "Ubuntu 16.04"
variables:
node_version: 10
steps:
- template: .azure-pipelines/lint.yml
- template: .azure-pipelines/jobs/dev-lint.yml
- job: Lint_Dist_Linux_Node_v10
displayName: Lint Dist on Linux Node v10
- job: Dev_Test_Windows
displayName: Dev Test on Windows Node v10
pool:
vmImage: "Ubuntu 16.04"
vmImage: vs2017-win2016
variables:
node_version: 10
TEST_CRLF: true
steps:
- template: .azure-pipelines/lint-dist.yml
- template: .azure-pipelines/jobs/dev-test.yml
- job: Dev_Test_Windows_Node_v10
displayName: Dev Tests on Windows Node v10
- job: Dev_Test_macOS
displayName: Dev Test on macOS Node v10
pool:
vmImage: vs2017-win2016
vmImage: macos-10.13
variables:
node_version: 10
TEST_CRLF: true
ENABLE_CODE_COVERAGE: true
steps:
- template: .azure-pipelines/dev.yml
- template: .azure-pipelines/jobs/dev-test.yml
- job: Dev_Test_macOS_Node_v10
displayName: Dev Tests on macOS Node v10
- job: Dev_Test_Linux
displayName: Dev Test on Linux Node v10
pool:
vmImage: macos-10.13
vmImage: "Ubuntu 16.04"
variables:
node_version: 10
steps:
- template: .azure-pipelines/dev.yml
- template: .azure-pipelines/jobs/dev-test.yml
- job: Dev_Test_Linux_Node_v10
displayName: Dev Tests on Linux Node v10
- job: Prod_Build
displayName: Prod Build on Linux Node v10
pool:
vmImage: "Ubuntu 16.04"
variables:
node_version: 10
steps:
- template: .azure-pipelines/dev.yml
- template: .azure-pipelines/jobs/prod-build.yml
- job: Prod_Test_Linux
displayName: Prod Tests on Linux
- job: Prod_Pack
dependsOn: Prod_Build
displayName: Prod Pack on Linux Node v10
pool:
vmImage: "Ubuntu 16.04"
variables:
node_version_for_build: 10
node_version: 10
steps:
- template: .azure-pipelines/jobs/prod-pack.yml
- job: Prod_Lint
dependsOn: Prod_Build
displayName: Prod Lint on Linux Node v10
pool:
vmImage: "Ubuntu 16.04"
variables:
node_version: 10
steps:
- template: .azure-pipelines/jobs/prod-lint.yml
- job: Prod_Test
dependsOn: Prod_Build
displayName: Prod Test on macOS
pool:
vmImage: macos-10.13
strategy:
matrix:
Node_v4:
node_version: 4
REPORT_SUMMARIES: "" # jest-junit requires node v6+
ENABLE_TEST_RESULTS: "" # jest-junit requires node v6+
Node_v10:
node_version: 10
Node_v10_standalone:
node_version: 10
TEST_STANDALONE: true
steps:
- template: .azure-pipelines/prod.yml
- template: .azure-pipelines/jobs/prod-test.yml

18
jest.config.js

@ -1,6 +1,7 @@
"use strict";
const ENABLE_COVERAGE = !!process.env.CI;
const ENABLE_TEST_RESULTS = !!process.env.ENABLE_TEST_RESULTS;
const ENABLE_CODE_COVERAGE = !!process.env.ENABLE_CODE_COVERAGE;
const requiresPrettierInternals = [
"tests_integration/__tests__/util-shared.js",
@ -20,13 +21,14 @@ module.exports = {
testPathIgnorePatterns: ["tests/new_react", "tests/more_react"].concat(
isOldNode ? requiresPrettierInternals : []
),
collectCoverage: ENABLE_COVERAGE,
collectCoverage: ENABLE_CODE_COVERAGE,
collectCoverageFrom: ["src/**/*.js", "index.js", "!<rootDir>/node_modules/"],
coveragePathIgnorePatterns: [
"<rootDir>/standalone.js",
"<rootDir>/src/doc/doc-debug.js",
"<rootDir>/src/main/massage-ast.js"
],
coverageReporters: ["text", "html", "cobertura"],
moduleNameMapper: {
// Jest wires `fs` to `graceful-fs`, which causes a memory leak when
// `graceful-fs` does `require('fs')`.
@ -43,15 +45,5 @@ module.exports = {
"jest-watch-typeahead/filename",
"jest-watch-typeahead/testname"
],
reporters: process.env.REPORT_SUMMARIES
? [
"default",
[
"jest-junit",
{
output: "./test-results/jest/junit.xml"
}
]
]
: undefined
reporters: ["default"].concat(ENABLE_TEST_RESULTS ? "jest-junit" : [])
};

2
package.json

@ -80,7 +80,7 @@
"babel-loader": "8.0.4",
"benchmark": "2.1.4",
"builtin-modules": "2.0.0",
"codecov": "2.2.0",
"codecov": "codecov/codecov-node#e427d900309adb50746a39a50aa7d80071a5ddd0",
"cross-env": "5.0.5",
"eslint": "4.18.2",
"eslint-config-prettier": "2.9.0",

215
yarn.lock

@ -712,6 +712,12 @@ acorn@^5.0.0, acorn@^5.2.1, acorn@^5.3.0, acorn@^5.5.0:
version "5.7.1"
resolved "https://registry.yarnpkg.com/acorn/-/acorn-5.7.1.tgz#f095829297706a7c9776958c0afc8930a9b9d9d8"
agent-base@^4.1.0:
version "4.2.1"
resolved "https://registry.yarnpkg.com/agent-base/-/agent-base-4.2.1.tgz#d89e5999f797875674c07d87f260fc41e83e8ca9"
dependencies:
es6-promisify "^5.0.0"
ajv-keywords@^2.1.0:
version "2.1.1"
resolved "https://registry.yarnpkg.com/ajv-keywords/-/ajv-keywords-2.1.1.tgz#617997fc5f60576894c435f940d819e135b80762"
@ -831,7 +837,7 @@ argparse@^1.0.7:
dependencies:
sprintf-js "~1.0.2"
argv@0.0.2:
argv@^0.0.2:
version "0.0.2"
resolved "https://registry.yarnpkg.com/argv/-/argv-0.0.2.tgz#ecbd16f8949b157183711b1bda334f37840185ab"
@ -910,10 +916,6 @@ assert-plus@1.0.0, assert-plus@^1.0.0:
version "1.0.0"
resolved "https://registry.yarnpkg.com/assert-plus/-/assert-plus-1.0.0.tgz#f12e0f3c5d77b0b1cdd9146942e4e96c1e4dd525"
assert-plus@^0.2.0:
version "0.2.0"
resolved "https://registry.yarnpkg.com/assert-plus/-/assert-plus-0.2.0.tgz#d74e1b87e7affc0db8aadb7021f3fe48101ab234"
assert@^1.1.1:
version "1.4.1"
resolved "https://registry.yarnpkg.com/assert/-/assert-1.4.1.tgz#99912d591836b5a6f5b345c0f07eefc08fc65d91"
@ -954,15 +956,11 @@ atob@^2.1.1:
version "2.1.1"
resolved "https://registry.yarnpkg.com/atob/-/atob-2.1.1.tgz#ae2d5a729477f289d60dd7f96a6314a22dd6c22a"
aws-sign2@~0.6.0:
version "0.6.0"
resolved "https://registry.yarnpkg.com/aws-sign2/-/aws-sign2-0.6.0.tgz#14342dd38dbcc94d0e5b87d763cd63612c0e794f"
aws-sign2@~0.7.0:
version "0.7.0"
resolved "https://registry.yarnpkg.com/aws-sign2/-/aws-sign2-0.7.0.tgz#b46e890934a9591f2d2f6f86d7e6a9f1b3fe76a8"
aws4@^1.2.1, aws4@^1.6.0:
aws4@^1.6.0:
version "1.7.0"
resolved "https://registry.yarnpkg.com/aws4/-/aws4-1.7.0.tgz#d4d0e9b9dbfca77bf08eeb0a8a471550fe39e289"
@ -1169,12 +1167,6 @@ bn.js@^4.0.0, bn.js@^4.1.0, bn.js@^4.1.1, bn.js@^4.4.0:
version "4.11.6"
resolved "https://registry.yarnpkg.com/bn.js/-/bn.js-4.11.6.tgz#53344adb14617a13f6e8dd2ce28905d1c0ba3215"
boom@2.x.x:
version "2.10.1"
resolved "https://registry.yarnpkg.com/boom/-/boom-2.10.1.tgz#39c8918ceff5799f83f9492a848f625add0c766f"
dependencies:
hoek "2.x.x"
brace-expansion@^1.1.7:
version "1.1.8"
resolved "https://registry.yarnpkg.com/brace-expansion/-/brace-expansion-1.1.8.tgz#c07b211c7c952ec1f8efd51a77ef0d1d3990a292"
@ -1381,10 +1373,6 @@ caniuse-lite@^1.0.30000912:
resolved "https://registry.yarnpkg.com/caniuse-lite/-/caniuse-lite-1.0.30000918.tgz#6288f79da3c5c8b45e502f47ad8f3eb91f1379a9"
integrity sha512-CAZ9QXGViBvhHnmIHhsTPSWFBujDaelKnUj7wwImbyQRxmXynYqKGi3UaZTSz9MoVh+1EVxOS/DFIkrJYgR3aw==
caseless@~0.11.0:
version "0.11.0"
resolved "https://registry.yarnpkg.com/caseless/-/caseless-0.11.0.tgz#715b96ea9841593cc33067923f5ec60ebda4f7d7"
caseless@~0.12.0:
version "0.12.0"
resolved "https://registry.yarnpkg.com/caseless/-/caseless-0.12.0.tgz#1b681c21ff84033c826543090689420d187151dc"
@ -1404,7 +1392,7 @@ chalk@2.1.0:
escape-string-regexp "^1.0.5"
supports-color "^4.0.0"
chalk@^1.0.0, chalk@^1.1.1, chalk@^1.1.3:
chalk@^1.0.0, chalk@^1.1.3:
version "1.1.3"
resolved "https://registry.yarnpkg.com/chalk/-/chalk-1.1.3.tgz#a8115c55e4a702fe4d150abd3872822a7e09fc98"
dependencies:
@ -1536,13 +1524,15 @@ code-point-at@^1.0.0:
version "1.1.0"
resolved "https://registry.yarnpkg.com/code-point-at/-/code-point-at-1.1.0.tgz#0d070b4d043a5bea33a2f1a40e2edb3d9a4ccf77"
codecov@2.2.0:
version "2.2.0"
resolved "https://registry.yarnpkg.com/codecov/-/codecov-2.2.0.tgz#2d06817ceb8891eca6368836d4fb6bf6cc04ffd1"
codecov@codecov/codecov-node#e427d900309adb50746a39a50aa7d80071a5ddd0:
version "3.1.0"
resolved "https://codeload.github.com/codecov/codecov-node/tar.gz/e427d900309adb50746a39a50aa7d80071a5ddd0"
dependencies:
argv "0.0.2"
request "2.79.0"
urlgrey "0.4.4"
argv "^0.0.2"
ignore-walk "^3.0.1"
js-yaml "^3.12.0"
teeny-request "^3.7.0"
urlgrey "^0.4.4"
collapse-white-space@^1.0.2:
version "1.0.3"
@ -1565,13 +1555,13 @@ color-name@^1.1.1:
version "1.1.2"
resolved "https://registry.yarnpkg.com/color-name/-/color-name-1.1.2.tgz#5c8ab72b64bd2215d617ae9559ebb148475cf98d"
combined-stream@1.0.6, combined-stream@^1.0.5, combined-stream@~1.0.5:
combined-stream@1.0.6, combined-stream@~1.0.5:
version "1.0.6"
resolved "https://registry.yarnpkg.com/combined-stream/-/combined-stream-1.0.6.tgz#723e7df6e801ac5613113a7e445a9b69cb632818"
dependencies:
delayed-stream "~1.0.0"
commander@^2.19.0, commander@^2.8.1, commander@^2.9.0:
commander@^2.19.0, commander@^2.8.1:
version "2.19.0"
resolved "https://registry.yarnpkg.com/commander/-/commander-2.19.0.tgz#f6198aa84e5b83c46054b94ddedbfed5ee9ff12a"
@ -1702,12 +1692,6 @@ cross-spawn@^6.0.0:
shebang-command "^1.2.0"
which "^1.2.9"
cryptiles@2.x.x:
version "2.0.5"
resolved "https://registry.yarnpkg.com/cryptiles/-/cryptiles-2.0.5.tgz#3bdfecdc608147c1c67202fa291e7dca59eaa3b8"
dependencies:
boom "2.x.x"
crypto-browserify@^3.11.0:
version "3.11.0"
resolved "https://registry.yarnpkg.com/crypto-browserify/-/crypto-browserify-3.11.0.tgz#3652a0906ab9b2a7e0c3ce66a408e957a2485522"
@ -2043,6 +2027,16 @@ es6-map@^0.1.3:
es6-symbol "~3.1.1"
event-emitter "~0.3.5"
es6-promise@^4.0.3:
version "4.2.5"
resolved "https://registry.yarnpkg.com/es6-promise/-/es6-promise-4.2.5.tgz#da6d0d5692efb461e082c14817fe2427d8f5d054"
es6-promisify@^5.0.0:
version "5.0.0"
resolved "http://registry.npmjs.org/es6-promisify/-/es6-promisify-5.0.0.tgz#5109d62f3e56ea967c4b63505aef08291c8a5203"
dependencies:
es6-promise "^4.0.3"
es6-set@~0.1.5:
version "0.1.5"
resolved "https://registry.yarnpkg.com/es6-set/-/es6-set-0.1.5.tgz#d2b3ec5d4d800ced818db538d28974db0a73ccb1"
@ -2368,7 +2362,7 @@ extend-shallow@^3.0.0, extend-shallow@^3.0.2:
assign-symbols "^1.0.0"
is-extendable "^1.0.1"
extend@^3.0.0, extend@~3.0.0, extend@~3.0.1:
extend@^3.0.0, extend@~3.0.1:
version "3.0.1"
resolved "https://registry.yarnpkg.com/extend/-/extend-3.0.1.tgz#a755ea7bc1adfcc5a31ce7e762dbaadc5e636444"
@ -2548,14 +2542,6 @@ forever-agent@~0.6.1:
version "0.6.1"
resolved "https://registry.yarnpkg.com/forever-agent/-/forever-agent-0.6.1.tgz#fbc71f0c41adeb37f96c577ad1ed42d8fdacca91"
form-data@~2.1.1:
version "2.1.4"
resolved "https://registry.yarnpkg.com/form-data/-/form-data-2.1.4.tgz#33c183acf193276ecaa98143a69e94bfee1750d1"
dependencies:
asynckit "^0.4.0"
combined-stream "^1.0.5"
mime-types "^2.1.12"
form-data@~2.3.1:
version "2.3.2"
resolved "https://registry.yarnpkg.com/form-data/-/form-data-2.3.2.tgz#4970498be604c20c005d4f5c23aecd21d6b49099"
@ -2612,16 +2598,6 @@ gauge@~2.7.3:
strip-ansi "^3.0.1"
wide-align "^1.1.0"
generate-function@^2.0.0:
version "2.0.0"
resolved "https://registry.yarnpkg.com/generate-function/-/generate-function-2.0.0.tgz#6858fe7c0969b7d4e9093337647ac79f60dfbe74"
generate-object-property@^1.1.0:
version "1.2.0"
resolved "https://registry.yarnpkg.com/generate-object-property/-/generate-object-property-1.2.0.tgz#9c0e1c40308ce804f4783618b937fa88f99d50d0"
dependencies:
is-property "^1.0.0"
get-caller-file@^1.0.1:
version "1.0.2"
resolved "https://registry.yarnpkg.com/get-caller-file/-/get-caller-file-1.0.2.tgz#f702e63127e7e231c160a80c1554acb70d5047e5"
@ -2736,15 +2712,6 @@ har-schema@^2.0.0:
version "2.0.0"
resolved "https://registry.yarnpkg.com/har-schema/-/har-schema-2.0.0.tgz#a94c2224ebcac04782a0d9035521f24735b7ec92"
har-validator@~2.0.6:
version "2.0.6"
resolved "https://registry.yarnpkg.com/har-validator/-/har-validator-2.0.6.tgz#cdcbc08188265ad119b6a5a7c8ab70eecfb5d27d"
dependencies:
chalk "^1.1.1"
commander "^2.9.0"
is-my-json-valid "^2.12.4"
pinkie-promise "^2.0.0"
har-validator@~5.0.3:
version "5.0.3"
resolved "https://registry.yarnpkg.com/har-validator/-/har-validator-5.0.3.tgz#ba402c266194f15956ef15e0fcf242993f6a7dfd"
@ -2825,15 +2792,6 @@ hash.js@^1.0.0, hash.js@^1.0.3:
dependencies:
inherits "^2.0.1"
hawk@~3.1.3:
version "3.1.3"
resolved "https://registry.yarnpkg.com/hawk/-/hawk-3.1.3.tgz#078444bd7c1640b0fe540d2c9b73d59678e8e1c4"
dependencies:
boom "2.x.x"
cryptiles "2.x.x"
hoek "2.x.x"
sntp "1.x.x"
hmac-drbg@^1.0.0:
version "1.0.1"
resolved "https://registry.yarnpkg.com/hmac-drbg/-/hmac-drbg-1.0.1.tgz#d2745701025a6c775a6c545793ed502fc0c649a1"
@ -2842,10 +2800,6 @@ hmac-drbg@^1.0.0:
minimalistic-assert "^1.0.0"
minimalistic-crypto-utils "^1.0.1"
hoek@2.x.x:
version "2.16.3"
resolved "https://registry.yarnpkg.com/hoek/-/hoek-2.16.3.tgz#20bb7403d3cea398e91dc4710a8ff1b8274a25ed"
home-or-tmp@^2.0.0:
version "2.0.0"
resolved "https://registry.yarnpkg.com/home-or-tmp/-/home-or-tmp-2.0.0.tgz#e36c3f2d2cae7d746a857e38d18d5f32a7882db8"
@ -2875,14 +2829,6 @@ html-tag-names@1.1.2:
version "1.1.2"
resolved "https://registry.yarnpkg.com/html-tag-names/-/html-tag-names-1.1.2.tgz#f65168964c5a9c82675efda882875dcb2a875c22"
http-signature@~1.1.0:
version "1.1.1"
resolved "https://registry.yarnpkg.com/http-signature/-/http-signature-1.1.1.tgz#df72e267066cd0ac67fb76adf8e134a8fbcf91bf"
dependencies:
assert-plus "^0.2.0"
jsprim "^1.2.2"
sshpk "^1.7.0"
http-signature@~1.2.0:
version "1.2.0"
resolved "https://registry.yarnpkg.com/http-signature/-/http-signature-1.2.0.tgz#9aecd925114772f3d95b65a60abb8f7c18fbace1"
@ -2895,6 +2841,13 @@ https-browserify@0.0.1:
version "0.0.1"
resolved "https://registry.yarnpkg.com/https-browserify/-/https-browserify-0.0.1.tgz#3f91365cabe60b77ed0ebba24b454e3e09d95a82"
https-proxy-agent@^2.2.1:
version "2.2.1"
resolved "https://registry.yarnpkg.com/https-proxy-agent/-/https-proxy-agent-2.2.1.tgz#51552970fa04d723e04c56d04178c3f92592bbc0"
dependencies:
agent-base "^4.1.0"
debug "^3.1.0"
iconv-lite@0.4.19, iconv-lite@^0.4.17, iconv-lite@^0.4.4, iconv-lite@~0.4.13:
version "0.4.19"
resolved "https://registry.yarnpkg.com/iconv-lite/-/iconv-lite-0.4.19.tgz#f7468f60135f5e5dad3399c0a81be9a1603a082b"
@ -3164,15 +3117,6 @@ is-hexadecimal@^1.0.0:
version "1.0.1"
resolved "https://registry.yarnpkg.com/is-hexadecimal/-/is-hexadecimal-1.0.1.tgz#6e084bbc92061fbb0971ec58b6ce6d404e24da69"
is-my-json-valid@^2.12.4:
version "2.16.0"
resolved "https://registry.yarnpkg.com/is-my-json-valid/-/is-my-json-valid-2.16.0.tgz#f079dd9bfdae65ee2038aae8acbc86ab109e3693"
dependencies:
generate-function "^2.0.0"
generate-object-property "^1.1.0"
jsonpointer "^4.0.0"
xtend "^4.0.0"
is-number@^2.1.0:
version "2.1.0"
resolved "https://registry.yarnpkg.com/is-number/-/is-number-2.1.0.tgz#01fcbbb393463a548f2f466cce16dece49db908f"
@ -3233,10 +3177,6 @@ is-promise@^2.1.0:
version "2.1.0"
resolved "https://registry.yarnpkg.com/is-promise/-/is-promise-2.1.0.tgz#79a2a9ece7f096e80f36d2b2f3bc16c1ff4bf3fa"
is-property@^1.0.0:
version "1.0.2"
resolved "https://registry.yarnpkg.com/is-property/-/is-property-1.0.2.tgz#57fe1c4e48474edd65b09911f26b1cd4095dda84"
is-regex@^1.0.4:
version "1.0.4"
resolved "https://registry.yarnpkg.com/is-regex/-/is-regex-1.0.4.tgz#5517489b547091b0930e095654ced25ee97e9491"
@ -3709,16 +3649,16 @@ js-tokens@^3.0.0, js-tokens@^3.0.2:
version "3.0.2"
resolved "https://registry.yarnpkg.com/js-tokens/-/js-tokens-3.0.2.tgz#9866df395102130e38f7f996bceb65443209c25b"
js-yaml@^3.7.0, js-yaml@^3.9.1:
version "3.10.0"
resolved "https://registry.yarnpkg.com/js-yaml/-/js-yaml-3.10.0.tgz#2e78441646bd4682e963f22b6e92823c309c62dc"
js-yaml@^3.12.0, js-yaml@^3.9.0:
version "3.12.0"
resolved "https://registry.yarnpkg.com/js-yaml/-/js-yaml-3.12.0.tgz#eaed656ec8344f10f527c6bfa1b6e2244de167d1"
dependencies:
argparse "^1.0.7"
esprima "^4.0.0"
js-yaml@^3.9.0:
version "3.12.0"
resolved "https://registry.yarnpkg.com/js-yaml/-/js-yaml-3.12.0.tgz#eaed656ec8344f10f527c6bfa1b6e2244de167d1"
js-yaml@^3.7.0, js-yaml@^3.9.1:
version "3.10.0"
resolved "https://registry.yarnpkg.com/js-yaml/-/js-yaml-3.10.0.tgz#2e78441646bd4682e963f22b6e92823c309c62dc"
dependencies:
argparse "^1.0.7"
esprima "^4.0.0"
@ -3823,10 +3763,6 @@ jsonify@~0.0.0:
version "0.0.0"
resolved "https://registry.yarnpkg.com/jsonify/-/jsonify-0.0.0.tgz#2c74b6ee41d93ca51b7b5aaee8f503631d252a73"
jsonpointer@^4.0.0:
version "4.0.1"
resolved "https://registry.yarnpkg.com/jsonpointer/-/jsonpointer-4.0.1.tgz#4fd92cb34e0e9db3c89c8622ecf51f9b978c6cb9"
jsprim@^1.2.2:
version "1.4.0"
resolved "https://registry.yarnpkg.com/jsprim/-/jsprim-1.4.0.tgz#a3b87e40298d8c380552d8cc7628a0bb95a22918"
@ -4110,7 +4046,7 @@ mime-db@~1.33.0:
version "1.33.0"
resolved "https://registry.yarnpkg.com/mime-db/-/mime-db-1.33.0.tgz#a3492050a5cb9b63450541e39d9788d2272783db"
mime-types@^2.1.12, mime-types@~2.1.17, mime-types@~2.1.7:
mime-types@^2.1.12, mime-types@~2.1.17:
version "2.1.18"
resolved "https://registry.yarnpkg.com/mime-types/-/mime-types-2.1.18.tgz#6f323f60a83d11146f831ff11fd66e2fe5503bb8"
dependencies:
@ -4237,6 +4173,10 @@ node-fetch@^1.0.1:
encoding "^0.1.11"
is-stream "^1.0.1"
node-fetch@^2.2.0:
version "2.3.0"
resolved "https://registry.yarnpkg.com/node-fetch/-/node-fetch-2.3.0.tgz#1a1d940bbfb916a1d3e0219f037e89e71f8c5fa5"
node-int64@^0.4.0:
version "0.4.0"
resolved "https://registry.yarnpkg.com/node-int64/-/node-int64-0.4.0.tgz#87a9065cdb355d3182d8f94ce11188b825c68a3b"
@ -4360,7 +4300,7 @@ nwsapi@^2.0.0:
version "2.0.4"
resolved "https://registry.yarnpkg.com/nwsapi/-/nwsapi-2.0.4.tgz#dc79040a5f77b97716dc79565fc7fc3ef7d50570"
oauth-sign@~0.8.1, oauth-sign@~0.8.2:
oauth-sign@~0.8.2:
version "0.8.2"
resolved "https://registry.yarnpkg.com/oauth-sign/-/oauth-sign-0.8.2.tgz#46a6ab7f0aead8deae9ec0565780b7d4efeb9d43"
@ -4809,10 +4749,6 @@ punycode@^2.1.0:
version "2.1.1"
resolved "https://registry.yarnpkg.com/punycode/-/punycode-2.1.1.tgz#b58b010ac40c22c5657616c8d2c2c02c7bf479ec"
qs@~6.3.0:
version "6.3.2"
resolved "https://registry.yarnpkg.com/qs/-/qs-6.3.2.tgz#e75bd5f6e268122a2a0e0bda630b2550c166502c"
qs@~6.5.1:
version "6.5.2"
resolved "https://registry.yarnpkg.com/qs/-/qs-6.5.2.tgz#cb3ae806e8740444584ef154ce8ee98d403f3e36"
@ -5040,31 +4976,6 @@ request-promise-native@^1.0.5:
stealthy-require "^1.1.0"
tough-cookie ">=2.3.3"
request@2.79.0:
version "2.79.0"
resolved "https://registry.yarnpkg.com/request/-/request-2.79.0.tgz#4dfe5bf6be8b8cdc37fcf93e04b65577722710de"
dependencies:
aws-sign2 "~0.6.0"
aws4 "^1.2.1"
caseless "~0.11.0"
combined-stream "~1.0.5"
extend "~3.0.0"
forever-agent "~0.6.1"
form-data "~2.1.1"
har-validator "~2.0.6"
hawk "~3.1.3"
http-signature "~1.1.0"
is-typedarray "~1.0.0"
isstream "~0.1.2"
json-stringify-safe "~5.0.1"
mime-types "~2.1.7"
oauth-sign "~0.8.1"
qs "~6.3.0"
stringstream "~0.0.4"
tough-cookie "~2.3.0"
tunnel-agent "~0.4.1"
uuid "^3.0.0"
request@^2.83.0:
version "2.87.0"
resolved "https://registry.yarnpkg.com/request/-/request-2.87.0.tgz#32f00235cd08d482b4d0d68db93a829c0ed5756e"
@ -5441,12 +5352,6 @@ snapshot-diff@0.4.0:
pretty-format "^23.0.1"
strip-ansi "^4.0.0"
sntp@1.x.x:
version "1.0.9"
resolved "https://registry.yarnpkg.com/sntp/-/sntp-1.0.9.tgz#6541184cc90aeea6c6e7b35e2659082443c66198"
dependencies:
hoek "2.x.x"
source-list-map@^2.0.0:
version "2.0.0"
resolved "https://registry.yarnpkg.com/source-list-map/-/source-list-map-2.0.0.tgz#aaa47403f7b245a92fbc97ea08f250d6087ed085"
@ -5607,10 +5512,6 @@ string_decoder@~1.0.0:
dependencies:
safe-buffer "~5.0.1"
stringstream@~0.0.4:
version "0.0.5"
resolved "https://registry.yarnpkg.com/stringstream/-/stringstream-0.0.5.tgz#4e484cd4de5a0bbbee18e46307710a8a81621878"
strip-ansi@4.0.0, strip-ansi@^4.0.0:
version "4.0.0"
resolved "https://registry.yarnpkg.com/strip-ansi/-/strip-ansi-4.0.0.tgz#a8479022eb1ac368a871389b635262c505ee368f"
@ -5707,6 +5608,14 @@ tar@^4:
safe-buffer "^5.1.2"
yallist "^3.0.2"
teeny-request@^3.7.0:
version "3.11.3"
resolved "https://registry.yarnpkg.com/teeny-request/-/teeny-request-3.11.3.tgz#335c629f7645e5d6599362df2f3230c4cbc23a55"
dependencies:
https-proxy-agent "^2.2.1"
node-fetch "^2.2.0"
uuid "^3.3.2"
temp-dir@^1.0.0:
version "1.0.0"
resolved "https://registry.yarnpkg.com/temp-dir/-/temp-dir-1.0.0.tgz#0a7c0ea26d3a39afa7e0ebea9c1fc0bc4daa011d"
@ -5790,7 +5699,7 @@ to-regex@^3.0.1, to-regex@^3.0.2:
regex-not "^1.0.2"
safe-regex "^1.1.0"
tough-cookie@>=2.3.3, tough-cookie@^2.3.3, tough-cookie@~2.3.0, tough-cookie@~2.3.3:
tough-cookie@>=2.3.3, tough-cookie@^2.3.3, tough-cookie@~2.3.3:
version "2.3.4"
resolved "https://registry.yarnpkg.com/tough-cookie/-/tough-cookie-2.3.4.tgz#ec60cee38ac675063ffc97a5c18970578ee83655"
dependencies:
@ -5840,10 +5749,6 @@ tunnel-agent@^0.6.0:
dependencies:
safe-buffer "^5.0.1"
tunnel-agent@~0.4.1:
version "0.4.3"
resolved "https://registry.yarnpkg.com/tunnel-agent/-/tunnel-agent-0.4.3.tgz#6373db76909fe570e08d73583365ed828a74eeeb"
tweetnacl@^0.14.3, tweetnacl@~0.14.0:
version "0.14.5"
resolved "https://registry.yarnpkg.com/tweetnacl/-/tweetnacl-0.14.5.tgz#5ae68177f192d4456269d108afa93ff8743f4f64"
@ -6006,7 +5911,7 @@ url@^0.11.0:
punycode "1.3.2"
querystring "0.2.0"
urlgrey@0.4.4:
urlgrey@^0.4.4:
version "0.4.4"
resolved "https://registry.yarnpkg.com/urlgrey/-/urlgrey-0.4.4.tgz#892fe95960805e85519f1cd4389f2cb4cbb7652f"
@ -6033,7 +5938,7 @@ util@0.10.3, util@^0.10.3:
dependencies:
inherits "2.0.1"
uuid@^3.0.0, uuid@^3.1.0:
uuid@^3.1.0, uuid@^3.3.2:
version "3.3.2"
resolved "https://registry.yarnpkg.com/uuid/-/uuid-3.3.2.tgz#1b4af4955eb3077c501c23872fc6513811587131"

Loading…
Cancel
Save